Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Problem - Samba
#1
Próbuje zainstalować Sambę przez Optware. Instalacja przebiega prawidłowo, tworzę prosty plik konfiguracyjny w /opt/etc/samba/smb.conf

Kod:
[global]
netbios name = Asus_HDP_R1
server string = Media_Player
workgroup = GRUPA_ROBOCZA
encrypt passwords = yes
smb passwd file = /opt/etc/samba/smbpasswd
security = user
map to guest = Bad User

[dane]
path = /opt/Downloads
guest ok = yes
write ok = yes

Ale kiedy wykonuję:

Kod:
/ # /opt/sbin/smbd
/ # /opt/sbin/nmbd
/ # ps -a

Uzyskuję coś takiego:
Kod:
PID  Uid     VmSize Stat Command
    1 root        100 S   init
    2 root            SWN [ksoftirqd/0]
    3 root            SW< [events/0]
    4 root            SW< [khelper]
    5 root            SW< [kthread]
    6 root            SW< [kblockd/0]
    7 root            SW  [khubd]
   11 root            SW< [aio/0]
   12 root            SW< [cifsoplockd]
   13 root            SW< [cifsdnotifyd]
   10 root            SW  [kswapd0]
   14 root            SW  [eth0]
   15 root            SW  [mtdblockd]
   27 root         56 S   init
   28 root         56 S   init
   31 root         56 S   init
   34 root         56 S   init
  160 root        124 S   inetd
  164 root            SW< [sata_eh/0]
  175 root            SW  [scsi_eh_0]
  177 root            SW  [scsi_eh_1]
  179 root        124 S   ./RootApp DvdPlayer
  180 root        124 S   ./RootApp DvdPlayer
  184 root       1764 S < DvdPlayer
  185 root        124 S   ./RootApp DvdPlayer
  186 root       1764 S   DvdPlayer
  187 root       1764 S N DvdPlayer
  188 root       1764 S N DvdPlayer
  195 root       1764 S   DvdPlayer
  196 root       1764 S   DvdPlayer
  199 root       1764 S   DvdPlayer
  201 root       1764 S   DvdPlayer
  202 root       1764 S   DvdPlayer
  203 root       1764 S   DvdPlayer
  204 root       1764 S   DvdPlayer
  205 root       1764 S   DvdPlayer
  206 root       1764 S   DvdPlayer
  207 root       1764 S   DvdPlayer
  208 root       1764 S   DvdPlayer
  209 root       1764 S   DvdPlayer
  210 root       1764 S   DvdPlayer
  229 root       1764 S   DvdPlayer
  234 root       1764 S   DvdPlayer
  235 root       1764 R N DvdPlayer
  236 root       1764 S   DvdPlayer
  237 root       1764 S   DvdPlayer
  238 root       1764 S   DvdPlayer
  239 root       1764 S   DvdPlayer
  257 root            SW  [scsi_eh_2]
  258 root            DW  [usb-storage]
  310 root            DWN [kjournald]
  327 root       4564 S   transmission-daemon -g /opt/Configs
  328 root       4564 S   transmission-daemon -g /opt/Configs
  329 root       4564 D   transmission-daemon -g /opt/Configs
  330 root       4564 S   transmission-daemon -g /opt/Configs
  406 root       1268 S   /opt/sbin/sshd
  712 root            SW  [pdflush]
  713 root            DW  [pdflush]
  811 root        304 S   telnetd
  812 root        536 S   -sh
  846 root        360 R   ps -a

Czyli procesy się nie uruchamiają.
Może ktoś bardziej obeznany w Linuxie pomógłby pociągnąć ten temat dalej?
Odpowiedz
#2
Masz zainstalowana nowsza wersje samby. Wpierw zagladnij do pliku :
Kod:
/opt/etc/init.d/S80samba
znajdziesz tam linie dotyczaca uruchamiania, domyslnie jest ustawiona na 0. Zmiana na 1 powinna pomoc.
Odpowiedz
#3
Dzięki, al skorzystałem już z twojego HOW-TO. Pozdrawiam.
Odpowiedz
#4
I jak ci dziala? Jakie masz transfery? Nie bylo problemow z Windows?
Odpowiedz


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości